Service Unavailable

Major incident Billing Email Platform Web
1 hour, 21 minutes

Updates

Resolved

This issue is resolved and we are continuing to monitor.

March 17, 2020 · 20:14 UTC
Monitoring

Load is improving and systems are becoming more responsive. We will continue monitoring.

March 17, 2020 · 19:37 UTC
Update

We are currently increasing database capacity to address the high load.

March 17, 2020 · 19:16 UTC
Investigating

The Haste platform is currently unavailable due to high usage. Current sessions will not be interrupted, but new sessions will be unable to start. We are investigating.

March 17, 2020 · 18:54 UTC