Service Unavailable

Major Incident Billing Email Platform Web
6 hours, 35 minutes

Update

Resolved

Platform responsiveness is optimal.

April 2th, 2020 at 02:35 UTC
Update

We have implemented a fix and are seeing improved responsiveness across our platform. A subset of users may receive errors when starting sessions. A fix is currently being developed for this issue.

April 1th, 2020 at 23:32 UTC
Investigating

The Haste platform is currently unavailable due to high usage. Current sessions will not be interrupted, but new sessions will be unable to start. We are investigating.

April 1th, 2020 at 20:00 UTC