Service Unavailable

Major incident Platform Web Billing Email
2020-04-02 17:51 UTC · 3 hours, 51 seconds

Updates

Resolved

Platform responsiveness is optimal.

April 2, 2020 · 20:52 UTC
Monitoring

We have implemented a fix and are continuing to monitor.

April 2, 2020 · 18:27 UTC
Investigating

The Haste platform is currently unavailable due to high usage. Current sessions will not be interrupted, but new sessions will be unable to start. We are investigating.

April 2, 2020 · 17:51 UTC

← Back