Service Unavailable

Major incident Platform Web Billing Email
2020-04-06 21:46 UTC · 52 minutes, 46 seconds

Updates

Resolved

Platform responsiveness is optimal.

April 6, 2020 · 22:39 UTC
Investigating

The Haste platform is currently unavailable due to high database utilization. Current sessions will not be interrupted, but new sessions will be unable to start. We are investigating.

April 6, 2020 · 21:46 UTC

← Back