Platform Degradation

Major incident Platform Web Billing Email
2020-04-24 19:13 UTC · 21 hours, 21 minutes, 14 seconds

Updates

Resolved

We’ve implemented a fix and are monitoring the impact.

April 25, 2020 · 16:35 UTC
Investigating

We are experiencing intermittent platform slowness. We are attempting to identify the root cause.

April 25, 2020 · 04:57 UTC
Investigating

Platform responsiveness is improving. We are continuing to investigate.

April 24, 2020 · 21:04 UTC
Issue

The Haste platform is currently experiencing a degradation in responsiveness. Current sessions will not be interrupted, but new sessions may be unable to start. We are investigating.

April 24, 2020 · 19:14 UTC

← Back