Email Outage

Major incident Billing Email Web
1 hour, 55 seconds

Updates

Resolved

This issue has been resolved.

June 24, 2020 · 19:09 UTC
Investigating

Our transactional email provider is experiencing issues. Automated emails will not be dispatched. MyAccount will be down while we investigate this issue.

June 24, 2020 · 18:12 UTC