Billing Outage

Major incident Web Billing
2020-09-16 16:36 UTC · 26 minutes, 13 seconds

Updates

Resolved

The outage with our payment processor has been resolved. MyAccount and billing are now available again.

September 16, 2020 · 17:03 UTC
Issue

Our payment processor is experiencing an outage. MyAccount has been put into maintenance mode as a precaution.

September 16, 2020 · 16:37 UTC

← Back