Platform Degradation

Major incident Platform
2020-11-25 19:02 UTC · 6 hours, 4 minutes, 31 seconds

Updates

Resolved

The Haste platform is now available for all users. We are continuing to monitor Amazon Web Services for errors.

November 26, 2020 · 01:06 UTC
Update

Haste Pro users now have access to Haste. We are continuing to monitor for errors before restoring access for Haste Free.

November 26, 2020 · 00:31 UTC
Update

MyAccount is available again. The Haste app will remain in maintenance mode while we wait for Amazon Web Services to resolve their outage.

November 25, 2020 · 21:47 UTC
Investigating

We are currently waiting for Amazon Web Services to resolve their outage so that we can begin recovery of our systems.

November 25, 2020 · 20:16 UTC
Investigating

We are continuing to evaluate ways to reduce the impact of the Amazon Web Services outage on our customers.

November 25, 2020 · 19:47 UTC
Investigating

The Haste platform is currently experiencing a degradation due to the Amazon Web Services outage. Current sessions will not be interrupted, but new sessions may be unable to start. MyAccount has been put into maintenance mode as a precaution. We are investigating.

November 25, 2020 · 19:03 UTC

← Back