Deliverability Issues for Outlook.com & Hotmail.com

Major incident Email
2020-12-03 18:30 UTC · 4 hours, 16 minutes, 41 seconds

Updates

Resolved

This issue is resolved. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 3, 2020 · 22:47 UTC
Investigating

We are working with our transactional email provider to resolve this issue. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 3, 2020 · 18:33 UTC
Issue

We are currently experiencing issues with delivering email to outlook.com and hotmail.com users. Users may not receive confirmation emails or account recovery emails. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 3, 2020 · 18:31 UTC

← Back