Deliverability Issue

Minor incident Email
2020-12-04 21:18 UTC · 2 days, 2 hours, 56 minutes, 58 seconds

Updates

Resolved

The deliverability issue has cleared up. We are working with our transactional email provider on a permanent resolution.

December 7, 2020 · 00:15 UTC
Monitoring

We are seeing improved delivery of emails. We are continuing to monitor. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 5, 2020 · 20:10 UTC
Monitoring

We are still waiting for the issue to clear up. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 5, 2020 · 16:27 UTC
Monitoring

We are currently waiting for the issue to clear up. The size of the queue has decreased substantially. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 5, 2020 · 03:38 UTC
Investigating

We are working with our email provider to investigate this issue. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 4, 2020 · 21:50 UTC
Issue

We are currently experiencing issues with delivering email. Users may not receive confirmation emails or account recovery emails. Users who need help confirming or recovering their accounts should contact Haste support at https://support.haste.net/hc/en-us/requests/new .

December 4, 2020 · 21:19 UTC

← Back