MyAccount Outage

Major incident Web Billing
2021-01-14 14:25 UTC · 3 hours, 3 minutes, 58 seconds

Updates

Resolved

This issue has been resolved.

January 14, 2021 · 17:29 UTC
Update

Users may still be experiencing intermittent issues when using MyAccount. We are continuing to make changes and monitor.

January 14, 2021 · 16:00 UTC
Monitoring

We have brought MyAccount online with some changes in place. We will continue to monitor.

January 14, 2021 · 15:35 UTC
Issue

MyAccount is experiencing an outage and has been placed in maintenance mode as we investigate this issue. Users will not be able to create accounts, recover accounts, manage accounts, manage billing, or purchase new subscriptions until service is restored. The Haste platform is not impacted.

January 14, 2021 · 14:26 UTC

← Back