Platform Degradation

Major incident Platform
2021-03-10 18:50 UTC · 1 hour, 37 minutes, 47 seconds

Updates

Resolved

This issue has been resolved. Please restart the Haste app if you continue to have issues.

March 10, 2021 · 20:28 UTC
Update

We have identified the issue and are implementing a resolution.

March 10, 2021 · 19:59 UTC
Investigating

We have enabled maintenance mode for Haste Pro users to further alleviate load. Haste users will not be able to use the Haste app at this time. We are continuing to investigate.

March 10, 2021 · 19:39 UTC
Investigating

Haste Free users have been placed in maintenance mode to alleviate load on our platform while we investigate this issue. Haste Free users will not be able to use Haste at this time.

March 10, 2021 · 19:10 UTC
Issue

We are experiencing a platform degradation. We are investigating.

March 10, 2021 · 18:52 UTC

← Back