Platform Degradation

Major incident Platform Web Billing Email
2021-03-14 15:00 UTC · 1 hour, 18 minutes, 31 seconds

Updates

Resolved

Service has been restored.

March 14, 2021 · 16:18 UTC
Monitoring

We have restored the platform and are monitoring.

March 14, 2021 · 15:32 UTC
Investigating

We are currently experiencing a platform degradation.

March 14, 2021 · 15:00 UTC

← Back