Platform Degradation

Major incident Platform Web Billing Email
2021-05-03 19:02 UTC · 3 hours, 24 minutes, 54 seconds

Updates

Resolved

This issue has been resolved.

May 3, 2021 · 22:27 UTC
Monitoring

We have deployed a resolution and are continuing to monitor.

May 3, 2021 · 22:03 UTC
Update

We are implementing a permanent resolution.

May 3, 2021 · 21:32 UTC
Update

We are working towards a permanent resolution.

May 3, 2021 · 20:49 UTC
Investigating

Platform performance has degraded again. We are investigating.

May 3, 2021 · 20:24 UTC
Monitoring

Platform performance is improving. We are continuing to monitor.

May 3, 2021 · 20:07 UTC
Investigating

We are investigating a platform issue.

May 3, 2021 · 19:03 UTC

← Back